PHP8.1.1でWordPress5.8.3がインストールできない

XAMPPのPHP8.1.1(2022/1/15最新)でWordPressの(おなじく最新)5.8.3で色々な問題が発生!

最初はXAMPPのDBインストールでMariaDBでフォルダーを作ったがエラーが発生!、デフォルトでインストールされていたでDBを「修復」で修正!

続いてwp-admin/install.php が画面真白 PHPのエラーフラグONでもエラー出ず。 1つの原因は、Wordpressがインストール済みか、さてれないかの検査でDBを確認しょうとして止まっている模様です! 現在調べていますが、PHPのバージョンを下げたほうが良いみたいです。

ググるとバージョンを下げてインストール後に上げる方法もあるようですが、PHPの8.0.13では正常にインストールできていますので8.1を使わず、8.0でも良いかなと思っています。

追記 2022/1/16
PHPのバージョンを8.0.14に下げたらインストール可能でした。(wp-admin/install.phpは動きました)PHP8.1.1で固まる場所はSQLとの接続のようです。Wordpareeの関数 get_option(‘siteurl’) などでも、帰ってきません。 DBはできてないのでDB参照でエラーになるはずです。

追記 2022/2/8
XAMPPのPHP8.1.1ならWorldpress5.9(2022/2/8最新)でインストール可能です。

XAMPPのリンク https://www.apachefriends.org/jp/download.html

XAMPPにインストールする方法!Youtube